CVE-2015-9096

NameCVE-2015-9096
DescriptionNet::SMTP in Ruby before 2.4.0 is vulnerable to SMTP command injection via CRLF sequences in a RCPT TO or MAIL FROM command, as demonstrated by CRLF sequences immediately before and after a DATA substring.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3966-1
NVD severitymedium (attack range: remote)
Debian Bugs864860

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)wheezy1.8.7.358-7.1+deb7u3vulnerable
wheezy (security)1.8.7.358-7.1+deb7u4vulnerable
ruby1.9.1 (PTS)wheezy1.9.3.194-8.1+deb7u5vulnerable
wheezy (security)1.9.3.194-8.1+deb7u6vulnerable
ruby2.1 (PTS)jessie2.1.5-2+deb8u3vulnerable
jessie (security)2.1.5-2+deb8u1vulnerable
ruby2.3 (PTS)buster, stretch2.3.3-1+deb9u1fixed
stretch (security)2.3.3-1+deb9u2fixed
sid2.3.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)(unfixed)medium
ruby1.9.1source(unstable)(unfixed)medium
ruby2.1source(unstable)(unfixed)medium
ruby2.3source(unstable)2.3.3-1+deb9u1medium864860
ruby2.3sourcestretch2.3.3-1+deb9u1mediumDSA-3966-1

Notes

[jessie] - ruby2.1 <no-dsa> (Minor issue)
[wheezy] - ruby1.9.1 <no-dsa> (Minor issue, Net::SMTP users should validate data they send too)
[wheezy] - ruby1.8 <no-dsa> (Minor issue, Net::SMTP users should validate data they send too)
https://github.com/ruby/ruby/commit/0827a7e52ba3d957a634b063bf5a391239b9ffee
https://github.com/rubysec/ruby-advisory-db/issues/215

Search for package or bug name: Reporting problems