CVE-2015-9251

NameCVE-2015-9251
DescriptionjQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jquery (PTS)wheezy1.7.2+dfsg-1vulnerable
jessie1.7.2+dfsg-3.2vulnerable
stretch3.1.1-2fixed
buster, sid3.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jquerysource(unstable)3.1.1-1medium

Notes

[jessie] - jquery <ignored> (Too intrusive to backport)
[wheezy] - jquery <ignored> (Too invasive to fix)
https://github.com/jquery/jquery/commit/f60729f3903d17917dc351f3ac87794de379b0cc
https://github.com/jquery/jquery/issues/2432
https://github.com/jquery/jquery/pull/2588
https://snyk.io/vuln/npm:jquery:20150627
only 3.0 was fixed upstream, because fix considered too invasive: https://github.com/jquery/jquery/issues/2432#issuecomment-290983196

Search for package or bug name: Reporting problems