CVE-2015-9262

NameCVE-2015-9262
Description_XcursorThemeInherits in library.c in libXcursor before 1.1.15 allows remote attackers to cause denial of service or potentially code execution via a one-byte heap overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1469-1
NVD severityhigh
Debian Bugs906012

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxcursor (PTS)stretch1:1.1.14-1+deb9u2fixed
stretch (security)1:1.1.14-1+deb9u1vulnerable
buster1:1.1.15-2fixed
bullseye, sid1:1.2.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxcursorsourcejessie1:1.1.14-1+deb8u2DLA-1469-1
libxcursorsourcestretch1:1.1.14-1+deb9u2
libxcursorsource(unstable)1:1.1.15-1low906012

Notes

https://bugs.freedesktop.org/show_bug.cgi?id=90857
https://cgit.freedesktop.org/xorg/lib/libXcursor/commit/?id=897213f36baf6926daf6d192c709cf627aa5fd05

Search for package or bug name: Reporting problems