CVE-2015-9268

NameCVE-2015-9268
DescriptionNullsoft Scriptable Install System (NSIS) before 2.49 has unsafe implicit linking against Version.dll. In other words, there is no protection mechanism in which a wrapper function resolves the dependency at an appropriate time during runtime.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nsis (PTS)jessie2.46-10vulnerable
stretch2.51-1fixed
buster, sid3.03-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nsissource(unstable)2.50-1

Notes

https://sourceforge.net/p/nsis/bugs/1125/

Search for package or bug name: Reporting problems