CVE-2016-10006

NameCVE-2016-10006
DescriptionIn OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that supports style with active content), you could bypass the library protections and supply executable code. The impact is XSS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1014981

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libowasp-antisamy-java (PTS)buster1.5.3+dfsg-1vulnerable
bookworm, sid, bullseye1.5.3+dfsg-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libowasp-antisamy-javasource(unstable)(unfixed)1014981

Notes

[bullseye] - libowasp-antisamy-java <no-dsa> (Minor issue)
[buster] - libowasp-antisamy-java <no-dsa> (Minor issue)
[stretch] - libowasp-antisamy-java <no-dsa> (Minor issue)
https://github.com/nahsra/antisamy/issues/2

Search for package or bug name: Reporting problems