CVE-2016-10159

NameCVE-2016-10159
DescriptionInteger overflow in the phar_parse_pharfile function in ext/phar/phar.c in PHP before 5.6.30 and 7.0.x before 7.0.15 allows remote attackers to cause a denial of service (memory consumption or application crash) via a truncated manifest entry in a PHAR archive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-818-1, DSA-3783-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)jessie5.6.30+dfsg-0+deb8u1fixed
jessie (security)5.6.33+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch (security), stretch7.0.27-0+deb9u1fixed
sid7.0.29-1fixed
php7.1 (PTS)buster, sid7.1.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)medium
php5sourcejessie5.6.30+dfsg-0+deb8u1mediumDSA-3783-1
php5sourcewheezy5.4.45-0+deb7u7mediumDLA-818-1
php7.0source(unstable)7.0.15-1medium
php7.1source(unstable)7.1.1-1medium

Notes

PHP Bug: http://bugs.php.net/73764
Fixed in 5.6.30, 7.0.15, 7.1.1

Search for package or bug name: Reporting problems