CVE-2016-10160

NameCVE-2016-10160
DescriptionOff-by-one error in the phar_parse_pharfile function in ext/phar/phar.c in PHP before 5.6.30 and 7.0.x before 7.0.15 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a crafted PHAR archive with an alias mismatch.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-818-1, DSA-3783-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.22-3fixed
php7.1 (PTS)buster, sid7.1.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)high
php5sourcejessie5.6.30+dfsg-0+deb8u1highDSA-3783-1
php5sourcewheezy5.4.45-0+deb7u7highDLA-818-1
php7.0source(unstable)7.0.15-1high
php7.1source(unstable)7.1.1-1high

Notes

PHP Bug: http://bugs.php.net/73768
Fixed in 5.6.30, 7.0.15, 7.1.1

Search for package or bug name: Reporting problems