DescriptionMultiple integer overflows in libXpm before 3.5.12, when a program requests parsing XPM extensions on a 64-bit platform, allow remote attackers to cause a denial of service (out-of-bounds write) or execute arbitrary code via (1) the number of extensions or (2) their concatenated length in a crafted XPM file, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-801-1, DSA-3772-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxpm (PTS)buster1:3.5.12-1fixed
buster (security)1:3.5.12-1+deb10u2fixed
bullseye (security), bullseye1:3.5.12-1.1+deb11u1fixed
bookworm, bookworm (security)1:3.5.12-1.1+deb12u1fixed
sid, trixie1:3.5.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


Fixed by:

Search for package or bug name: Reporting problems