CVE-2016-10167

NameCVE-2016-10167
DescriptionThe gdImageCreateFromGd2Ctx function in gd_gd2.c in the GD Graphics Library (aka libgd) before 2.2.4 allows remote attackers to cause a denial of service (application crash) via a crafted image file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-804-1, DSA-3777-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2vulnerable
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie2.1.0-5+deb8u9fixed
jessie (security)2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-3fixed
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11vulnerable
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.22-3fixed
php7.1 (PTS)buster, sid7.1.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.4-1medium
libgd2sourcejessie2.1.0-5+deb8u9mediumDSA-3777-1
libgd2sourcewheezy2.0.36~rc1~dfsg-6.1+deb7u8mediumDLA-804-1
php5source(unstable)(unfixed)unimportant
php5sourcejessie5.6.30+dfsg-0+deb8u1medium
php7.0source(unstable)7.0.15-1unimportant
php7.1source(unstable)7.1.1-1unimportant

Notes

PHP Bug: https://bugs.php.net/bug.php?id=73868
Fixed in PHP 7.1.1, 7.0.15, 5.6.30
https://github.com/libgd/libgd/commit/fe9ed49dafa993e3af96b6a5a589efeea9bfb36f
http://www.openwall.com/lists/oss-security/2017/01/26/1

Search for package or bug name: Reporting problems