CVE-2016-10168

NameCVE-2016-10168
DescriptionInteger overflow in gd_io.c in the GD Graphics Library (aka libgd) before 2.2.4 allows remote attackers to have unspecified impact via vectors involving the number of horizontal and vertical chunks in an image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-804-1, DSA-3777-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)jessie2.1.0-5+deb8u11fixed
jessie (security)2.1.0-5+deb8u14fixed
stretch2.2.4-2+deb9u5fixed
stretch (security)2.2.4-2+deb9u4fixed
bullseye, sid, buster2.2.5-5.2fixed
php5 (PTS)jessie5.6.33+dfsg-0+deb8u1fixed
jessie (security)5.6.40+dfsg-0+deb8u8fixed
php7.0 (PTS)stretch7.0.33-0+deb9u6fixed
stretch (security)7.0.33-0+deb9u7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.4-1
libgd2sourcejessie2.1.0-5+deb8u9DSA-3777-1
libgd2sourcewheezy2.0.36~rc1~dfsg-6.1+deb7u8DLA-804-1
php5source(unstable)(unfixed)unimportant
php5sourcejessie5.6.30+dfsg-0+deb8u1
php7.0source(unstable)7.0.15-1unimportant
php7.1source(unstable)7.1.1-1unimportant

Notes

PHP Bug: https://bugs.php.net/bug.php?id=73869
Fixed in PHP 7.1.1, 7.0.15, 5.6.30
https://github.com/libgd/libgd/commit/69d2fd2c597ffc0c217de1238b9bf4d4bceba8e6
http://www.openwall.com/lists/oss-security/2017/01/26/1

Search for package or bug name: Reporting problems