CVE-2016-10191

NameCVE-2016-10191
DescriptionHeap-based buffer overflow in libavformat/rtmppkt.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 allows remote attackers to execute arbitrary code by leveraging failure to check for RTMP packet size mismatches.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1611-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch (security), stretch7:3.2.14-1~deb9u1fixed
buster, buster (security)7:4.1.4-1~deb10u1fixed
bullseye, sid7:4.2.1-2fixed
libav (PTS)jessie6:11.12-1~deb8u1vulnerable
jessie (security)6:11.12-1~deb8u8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:3.2.2-1
libavsource(unstable)(unfixed)
libavsourcejessie6:11.12-1~deb8u2DLA-1611-1

Notes

Patch: https://github.com/FFmpeg/FFmpeg/commit/7d57ca4d9a75562fa32e40766211de150f8b3ee7
http://www.openwall.com/lists/oss-security/2017/01/31/12

Search for package or bug name: Reporting problems