CVE-2016-10324

NameCVE-2016-10324
DescriptionIn libosip2 in GNU oSIP 4.1.0, a malformed SIP message can lead to a heap buffer overflow in the osip_clrncpy() function defined in osipparser2/osip_port.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-898-1, DSA-3879-1
NVD severityhigh (attack range: remote)
Debian Bugs860287

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libosip2 (PTS)wheezy3.6.0-4vulnerable
wheezy (security)3.6.0-4+deb7u1fixed
jessie, jessie (security)4.1.0-2+deb8u1fixed
buster, sid, stretch4.1.0-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libosip2source(unstable)4.1.0-2.1high860287
libosip2sourcejessie4.1.0-2+deb8u1highDSA-3879-1
libosip2sourcewheezy3.6.0-4+deb7u1highDLA-898-1

Notes

https://savannah.gnu.org/support/index.php?109133
https://git.savannah.gnu.org/cgit/osip.git/commit/?id=7e0793e15e21f68337e130c67b031ca38edf055f

Search for package or bug name: Reporting problems