CVE-2016-10707

NameCVE-2016-10707
DescriptionjQuery 3.0.0-rc.1 is vulnerable to Denial of Service (DoS) due to removing a logic that lowercased attribute names. Any attribute getter using a mixed-cased name for boolean attributes goes into an infinite recursion, exceeding the stack call limit.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jquery (PTS)stretch3.1.1-2+deb9u1fixed
stretch (security)3.1.1-2+deb9u2fixed
buster3.3.1~dfsg-3+deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jquerysource(unstable)(not affected)

Notes

- jquery <not-affected> (Vulnerable code never in unstable; only experimental)
https://github.com/jquery/jquery/issues/3133
https://github.com/jquery/jquery/pull/3134
https://snyk.io/vuln/npm:jquery:20160529
Only 3.0.0-rc1 affected: https://github.com/jquery/jquery/issues/3133#issuecomment-358978489

Search for package or bug name: Reporting problems