CVE-2016-10735

NameCVE-2016-10735
DescriptionIn Bootstrap 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute, a different vulnerability than CVE-2018-14041.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
twitter-bootstrap3 (PTS)jessie3.2.0+dfsg-1vulnerable
jessie (security)3.2.0+dfsg-1+deb7u1vulnerable
stretch3.3.7+dfsg-2vulnerable
buster, sid3.4.0+dfsg-1fixed
twitter-bootstrap4 (PTS)buster, sid4.2.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
twitter-bootstrap3source(unstable)3.4.0+dfsg-1medium
twitter-bootstrap4source(unstable)(not affected)

Notes

- twitter-bootstrap4 <not-affected> (Fixed before initial upload to Debian)
[stretch] - twitter-bootstrap3 <no-dsa> (Minor issue)
[jessie] - twitter-bootstrap3 <no-dsa> (Minor issue)
https://github.com/twbs/bootstrap/commit/bcad4bcb5f5a9ef079b2883a48a698b35261e083 (v4.0.0-beta.2)
https://github.com/twbs/bootstrap/commit/29f9237f735b90dbc89e003db0c62dec2db0b308 (v3.4.0)
https://github.com/twbs/bootstrap/commit/13bf8aeae3db71e28af69782328c22215795c169 (v3.4.0)
https://github.com/twbs/bootstrap/issues/20184
hhtps://github.com/twbs/bootstrap/issues/27915#issuecomment-452140906
https://github.com/twbs/bootstrap/pull/23679
https://github.com/twbs/bootstrap/pull/23687
https://github.com/twbs/bootstrap/pull/26460

Search for package or bug name: Reporting problems