CVE-2016-1248

NameCVE-2016-1248
Descriptionvim before patch 8.0.0056 does not properly validate values for the 'filetype', 'syntax' and 'keymap' options, which may result in the execution of arbitrary code if a file with a specially crafted modeline is opened.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-718-1, DSA-3722-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
neovim (PTS)stretch (security), stretch0.1.7-4+deb9u1fixed
buster0.3.4-3fixed
bullseye0.4.4-1fixed
bookworm, sid0.5.1-1fixed
vim (PTS)stretch (security), stretch2:8.0.0197-4+deb9u3fixed
buster2:8.1.0875-5fixed
bullseye2:8.2.2434-3fixed
bookworm, sid2:8.2.3455-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
neovimsource(unstable)0.1.6-4
vimsourcewheezy2:7.3.547-7+deb7u1DLA-718-1
vimsourcejessie2:7.4.488-7+deb8u1DSA-3722-1
vimsource(unstable)2:8.0.0095-1

Notes

Fixed by: https://github.com/vim/vim/commit/d0b5138ba4bccff8a744c99836041ef6322ed39a
Fixed by (neovim): https://github.com/neovim/neovim/commit/4fad66fbe637818b6b3d6bc5d21923ba72795040

Search for package or bug name: Reporting problems