CVE-2016-1494

NameCVE-2016-1494
DescriptionThe verify function in the RSA package for Python (Python-RSA) before 3.3 allows attackers to spoof signatures with a small public exponent via crafted signature padding, aka a BERserk attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs809980

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-rsa (PTS)buster4.0-2fixed
bullseye4.0-4fixed
bookworm, sid4.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-rsasourcejessie3.1.4-1+deb8u1
python-rsasource(unstable)3.2.3-1.1809980

Notes

proposed fix: https://bitbucket.org/sybren/python-rsa/pull-requests/14/security-fix-bb06-attack-in-verify-by/diff
https://blog.filippo.io/bleichenbacher-06-signature-forgery-in-python-rsa/

Search for package or bug name: Reporting problems