CVE-2016-1624

NameCVE-2016-1624
DescriptionInteger underflow in the ProcessCommandsInternal function in dec/decode.c in Brotli, as used in Google Chrome before 48.0.2564.109, allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via crafted data with brotli compression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3486-1
NVD severitymedium (attack range: remote)
Debian Bugs817233

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
brotli (PTS)stretch0.5.2+dfsg-2fixed
buster, sid0.6.0-1fixed
chromium-browser (PTS)wheezy, wheezy (security)37.0.2062.120-1~deb7u1vulnerable
jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch61.0.3163.100-1~deb9u1fixed
stretch (security)62.0.3202.89-1~deb9u1fixed
buster, sid62.0.3202.89-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
brotlisource(unstable)0.3.0+dfsg-3medium817233
chromium-browsersource(unstable)48.0.2564.116-1medium
chromium-browsersourcejessie48.0.2564.116-1~deb8u1mediumDSA-3486-1
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersourcewheezy(unfixed)end-of-life

Notes

[wheezy] - chromium-browser <end-of-life> (Not supported in Wheezy)
[squeeze] - chromium-browser <end-of-life> (Not supported in Squeeze LTS)
https://codereview.chromium.org/1662313002
https://codereview.chromium.org/1662313002/diff/1/third_party/brotli/dec/decode.c
Same fix/change as for CVE-2016-1968

Search for package or bug name: Reporting problems