CVE-2016-1882

NameCVE-2016-1882
DescriptionFreeBSD 9.3 before p33, 10.1 before p26, and 10.2 before p9 allow remote attackers to cause a denial of service (kernel crash) via vectors related to creating a TCP connection with the TCP_MD5SIG and TCP_NOOPT socket options.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs811280

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kfreebsd-10 (PTS)jessie10.1~svn274115-4vulnerable
sid, stretch10.3~svn300087-3fixed
kfreebsd-9 (PTS)wheezy, wheezy (security)9.0-10+deb70.10vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kfreebsd-10source(unstable)10.3~svn296373-1unimportant811280
kfreebsd-9source(unstable)(unfixed)high
kfreebsd-9sourcewheezy(unfixed)end-of-life

Notes

kfreebsd not covered by security support in Jessie
[wheezy] - kfreebsd-9 <end-of-life> (Unsupported in wheezy-lts)

Search for package or bug name: Reporting problems