CVE-2016-1968

NameCVE-2016-1968
DescriptionInteger underflow in Brotli, as used in Mozilla Firefox before 45.0, allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow) via crafted data with brotli compression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs817233

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
brotli (PTS)stretch0.5.2+dfsg-2fixed
buster, bullseye, sid1.0.7-2fixed
firefox (PTS)sid69.0-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)60.9.0esr-1~deb8u1fixed
stretch60.7.1esr-1~deb9u1fixed
stretch (security)60.9.0esr-1~deb9u1fixed
buster60.8.0esr-1~deb10u1fixed
buster (security)60.9.0esr-1~deb10u1fixed
bullseye60.8.0esr-1fixed
sid68.1.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
brotlisource(unstable)0.3.0+dfsg-3medium817233
firefoxsource(unstable)45.0-1medium
firefox-esrsource(unstable)45.0esr-1medium
iceweaselsource(unstable)(unfixed)medium
iceweaselsourcejessie(not affected)
iceweaselsourcewheezy(not affected)

Notes

[jessie] - iceweasel <not-affected> (Only affects Firefox 44.x)
[wheezy] - iceweasel <not-affected> (Only affects Firefox 44.x)
https://www.mozilla.org/en-US/security/advisories/mfsa2016-30/
https://github.com/google/brotli/commit/37a320dd81db8d546cd24a45b4c61d87b45dcade

Search for package or bug name: Reporting problems