CVE-2016-1978

NameCVE-2016-1978
DescriptionUse-after-free vulnerability in the ssl3_HandleECDHServerKeyExchange function in Mozilla Network Security Services (NSS) before 3.21, as used in Mozilla Firefox before 44.0, allows remote attackers to cause a denial of service or possibly have unspecified other impact by making an SSL (1) DHE or (2) ECDHE handshake at a time of high memory consumption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-480-1, DSA-3688-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceweasel (PTS)wheezy, wheezy (security)38.8.0esr-1~deb7u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed
nss (PTS)wheezy2:3.14.5-1+deb7u5fixed
wheezy (security)2:3.26-1+debu7u4fixed
jessie2:3.26-1+debu8u2fixed
jessie (security)2:3.26-1+debu8u3fixed
stretch2:3.26.2-1.1fixed
stretch (security)2:3.26.2-1.1+deb9u1fixed
buster, sid2:3.33-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceweaselsource(unstable)44.0-1high
iceweaselsourcejessie(not affected)
iceweaselsourcewheezy(not affected)
nsssource(unstable)2:3.21-1high
nsssourcejessie2:3.26-1+debu8u1highDSA-3688-1
nsssourcewheezy3.14.5-1+deb7u6highDLA-480-1

Notes

[jessie] - iceweasel <not-affected> (Only affects Firefox 43.x)
[wheezy] - iceweasel <not-affected> (Only affects Firefox 43.x)
Marked as fixed in 44.0-1 which would be the version fixing
the issue while using the bundled nss version. iceweasel for
unstable though used the system library.
https://www.mozilla.org/en-US/security/advisories/mfsa2016-15/

Search for package or bug name: Reporting problems