CVE-2016-20011

NameCVE-2016-20011
Descriptionlibgrss through 0.7.0 fails to perform TLS certificate verification when downloading feeds, allowing remote attackers to manipulate the contents of feeds without detection. This occurs because of the default behavior of SoupSessionSync.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs989149

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgrss (PTS)bullseye, sid, buster, stretch0.7.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgrsssource(unstable)(unfixed)989149

Notes

[bullseye] - libgrss <ignored> (Minor issue)
[buster] - libgrss <ignored> (Minor issue)
[stretch] - libgrss <ignored> (Minor issue)
https://bugzilla.gnome.org/show_bug.cgi?id=772647
https://gitlab.gnome.org/GNOME/libgrss/-/issues/4

Search for package or bug name: Reporting problems