CVE-2016-2054

NameCVE-2016-2054
DescriptionMultiple buffer overflows in xymond/xymond.c in xymond in Xymon 4.1.x, 4.2.x, and 4.3.x before 4.3.25 allow remote attackers to execute arbitrary code or cause a denial of service (daemon crash) via a long filename, involving handling a "config" command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-488-1, DSA-3495-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xymon (PTS)wheezy4.3.0~beta2.dfsg-9.1vulnerable
wheezy (security)4.3.0~beta2.dfsg-9.1+deb7u1fixed
jessie (security), jessie4.3.17-6+deb8u1fixed
buster, sid, stretch4.3.28-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xymonsource(unstable)4.3.25-1high
xymonsourcejessie4.3.17-6+deb8u1highDSA-3495-1
xymonsourcewheezy4.3.0~beta2.dfsg-9.1+deb7u1highDLA-488-1

Notes

http://lists.xymon.com/pipermail/xymon/2016-February/042986.html

Search for package or bug name: Reporting problems