CVE-2016-2057

NameCVE-2016-2057
Descriptionlib/xymond_ipc.c in Xymon 4.1.x, 4.2.x, and 4.3.x before 4.3.25 use weak permissions (666) for an unspecified IPC message queue, which allows local users to inject arbitrary messages by writing to that queue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3495-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xymon (PTS)buster4.3.28-5+deb10u1fixed
bookworm, bullseye4.3.30-1fixed
sid, trixie4.3.30-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xymonsourcewheezy(not affected)
xymonsourcejessie4.3.17-6+deb8u1DSA-3495-1
xymonsource(unstable)4.3.25-1

Notes

[wheezy] - xymon <not-affected> (vulnerable code not present)
http://lists.xymon.com/pipermail/xymon/2016-February/042986.html

Search for package or bug name: Reporting problems