CVE-2016-2058

NameCVE-2016-2058
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in Xymon 4.1.x, 4.2.x, and 4.3.x before 4.3.25 allow (1) remote Xymon clients to inject arbitrary web script or HTML via a status-message, which is not properly handled in the "detailed status" page, or (2) remote authenticated users to inject arbitrary web script or HTML via an acknowledgement message, which is not properly handled in the "status" page.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-488-1, DSA-3495-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xymon (PTS)wheezy4.3.0~beta2.dfsg-9.1vulnerable
wheezy (security)4.3.0~beta2.dfsg-9.1+deb7u1fixed
jessie (security), jessie4.3.17-6+deb8u1fixed
buster, sid, stretch4.3.28-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xymonsource(unstable)4.3.25-1low
xymonsourcejessie4.3.17-6+deb8u1lowDSA-3495-1
xymonsourcewheezy4.3.0~beta2.dfsg-9.1+deb7u1lowDLA-488-1

Notes

http://lists.xymon.com/pipermail/xymon/2016-February/042986.html

Search for package or bug name: Reporting problems