DescriptionOff-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libbsd (PTS)jessie0.7.0-2vulnerable
bullseye, sid0.10.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libbsdsourcesqueeze(not affected)
libbsdsourcewheezy(not affected)


[jessie] - libbsd <no-dsa> (Minor issue)
[wheezy] - libbsd <not-affected> (Vulnerable code not present)
[squeeze] - libbsd <not-affected> (Vulnerable code not present)
Not used anywhere in Debian according to
Fixed by: (0.8.2)
Introduced by: (0.5.0)

Search for package or bug name: Reporting problems