CVE-2016-2090

NameCVE-2016-2090
DescriptionOff-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libbsd (PTS)wheezy0.4.2-1fixed
jessie0.7.0-2vulnerable
stretch0.8.3-1fixed
buster, sid0.8.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libbsdsource(unstable)0.8.2-1high
libbsdsourcesqueeze(not affected)
libbsdsourcewheezy(not affected)

Notes

[jessie] - libbsd <no-dsa> (Minor issue)
[wheezy] - libbsd <not-affected> (Vulnerable code not present)
[squeeze] - libbsd <not-affected> (Vulnerable code not present)
Not used anywhere in Debian according to codesearch.debian.net
https://blog.fuzzing-project.org/36-Heap-buffer-overflow-in-fgetwln-function-of-libbsd.html
https://bugs.freedesktop.org/show_bug.cgi?id=93881
Fixed by: http://cgit.freedesktop.org/libbsd/commit/?id=c8f0723d2b4520bdd6b9eb7c3e7976de726d7ff7 (0.8.2)
Introduced by: http://cgit.freedesktop.org/libbsd/commit/?id=a97ce513e031b29a47965b740be14fb9a84277fc (0.5.0)

Search for package or bug name: Reporting problems