CVE-2016-2222

NameCVE-2016-2222
DescriptionThe wp_http_validate_url function in wp-includes/http.php in WordPress before 4.4.2 allows remote attackers to conduct server-side request forgery (SSRF) attacks via a zero value in the first octet of an IPv4 address in the u parameter to wp-admin/press-this.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-418-1, DSA-3472-1
NVD severitymedium (attack range: remote)
Debian Bugs813697

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u19fixed
jessie, jessie (security)4.1+dfsg-1+deb8u15fixed
stretch, stretch (security)4.7.5+dfsg-2+deb9u1fixed
buster, sid4.9.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.4.2+dfsg-1medium813697
wordpresssourcejessie4.1+dfsg-1+deb8u8mediumDSA-3472-1
wordpresssourcesqueeze3.6.1+dfsg-1~deb6u9mediumDLA-418-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u10mediumDSA-3472-1

Notes

https://wordpress.org/news/2016/02/wordpress-4-4-2-security-and-maintenance-release/
https://core.trac.wordpress.org/changeset/36435
http://www.openwall.com/lists/oss-security/2016/02/04/4

Search for package or bug name: Reporting problems