CVE-2016-2233

NameCVE-2016-2233
DescriptionStack-based buffer overflow in the inbound_cap_ls function in common/inbound.c in HexChat 2.10.2 allows remote IRC servers to cause a denial of service (crash) via a large number of options in a CAP LS message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hexchat (PTS)jessie2.10.1-1+deb8u2vulnerable
stretch2.12.4-3fixed
buster2.14.2-4fixed
bullseye, sid2.14.2-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hexchatsource(unstable)2.12.0-1low

Notes

[jessie] - hexchat <no-dsa> (Minor issue, requires connection to a malicious server)
https://www.exploit-db.com/exploits/39657/
https://github.com/hexchat/hexchat/issues/1934
https://github.com/hexchat/hexchat/commit/4e061a43b3453a9856d34250c3913175c45afe9d

Search for package or bug name: Reporting problems