CVE-2016-2315

NameCVE-2016-2315
Descriptionrevision.c in git before 2.7.4 uses an incorrect integer data type, which allows remote attackers to execute arbitrary code via a (1) long filename or (2) many nested trees, leading to a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3521-1
NVD severityhigh
Debian Bugs818318

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cgit (PTS)stretch (security), stretch1.1+git2.10.2-3+deb9u1fixed
buster1.2.1+git2.18.0-1fixed
bullseye, sid1.2.3+git2.25.1-1fixed
git (PTS)stretch (security), stretch1:2.11.0-3+deb9u7fixed
buster, buster (security)1:2.20.1-2+deb10u3fixed
bullseye1:2.30.2-1fixed
sid1:2.31.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cgitsource(unstable)(not affected)
gitsourcewheezy1:1.7.10.4-1+wheezy3DSA-3521-1
gitsourcejessie1:2.1.4-2.1+deb8u2DSA-3521-1
gitsource(unstable)1:2.7.0-1818318

Notes

https://github.com/git/git/commit/34fa79a6cde56d6d428ab0d3160cb094ebad3305 (v2.7.0-rc0)
- cgit <not-affected> (path_name function from embedded git is not called)

Search for package or bug name: Reporting problems