CVE-2016-2384

NameCVE-2016-2384
DescriptionDouble free vulnerability in the snd_usbmidi_create function in sound/usb/midi.c in the Linux kernel before 4.5 allows physically proximate attackers to cause a denial of service (panic) or possibly have unspecified other impact via vectors involving an invalid USB descriptor.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-439-1, DSA-3503-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)buster4.19.249-2fixed
buster (security)4.19.260-1fixed
bullseye5.10.140-1fixed
bullseye (security)5.10.136-1fixed
bookworm, sid5.19.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcewheezy3.2.73-2+deb7u3DSA-3503-1
linuxsourcejessie3.16.7-ckt20-1+deb8u4DSA-3503-1
linuxsource(unstable)4.4.2-1
linux-2.6sourcesqueeze2.6.32-48squeeze20DLA-439-1
linux-2.6source(unstable)(unfixed)

Notes

Fixed by: https://git.kernel.org/linus/07d86ca93db7e5cdf4743564d98292042ec21af7 (v4.5-rc4)
https://www.openwall.com/lists/oss-security/2016/02/14/2
https://xairy.github.io/blog/2016/cve-2016-2384

Search for package or bug name: Reporting problems