CVE-2016-2788

NameCVE-2016-2788
DescriptionMCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote attackers to execute arbitrary code via vectors related to the mco ping command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs850968

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mcollective (PTS)wheezy2.0.0+dfsg-2vulnerable
sid, jessie2.6.0+dfsg-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mcollectivesource(unstable)(unfixed)high850968

Notes

https://puppet.com/security/cve/cve-2016-2788

Search for package or bug name: Reporting problems