CVE-2016-2834

NameCVE-2016-2834
DescriptionMozilla Network Security Services (NSS) before 3.23, as used in Mozilla Firefox before 47.0, allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly have unspecified other impact via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-527-1, DSA-3688-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid107.0-1fixed
firefox-esr (PTS)buster91.12.0esr-1~deb10u1fixed
buster (security)102.5.0esr-1~deb10u1fixed
bullseye91.13.0esr-1~deb11u1fixed
bullseye (security)102.5.0esr-1~deb11u1fixed
bookworm, sid102.5.0esr-1fixed
nss (PTS)buster, buster (security)2:3.42.1-1+deb10u5fixed
bullseye (security), bullseye2:3.61-1+deb11u2fixed
bookworm, sid2:3.85-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)47.0-1
firefox-esrsource(unstable)(not affected)
nsssourcewheezy2:3.14.5-1+deb7u8DLA-527-1
nsssourcejessie2:3.26-1+debu8u1DSA-3688-1
nsssource(unstable)2:3.23-1

Notes

- firefox-esr <not-affected> (Doesn't apply to Firefox ESR)
https://www.mozilla.org/en-US/security/advisories/mfsa2016-61/

Search for package or bug name: Reporting problems