CVE-2016-3115

NameCVE-2016-3115
DescriptionMultiple CRLF injection vulnerabilities in session.c in sshd in OpenSSH before 7.2p2 allow remote authenticated users to bypass intended shell-command restrictions via crafted X11 forwarding data, related to the (1) do_authenticated1 and (2) session_x11_req functions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1500-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)jessie1:6.7p1-5+deb8u4vulnerable
jessie (security)1:6.7p1-5+deb8u7fixed
stretch (security), stretch1:7.4p1-10+deb9u4fixed
buster, sid1:7.9p1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsource(unstable)1:7.2p2-1medium
opensshsourcejessie1:6.7p1-5+deb8u6mediumDLA-1500-1

Notes

[wheezy] - openssh <no-dsa> (Minor issue)
http://www.openssh.com/txt/x11fwd.adv
Portable OpenSSH 7.2p2 contains a fix for this vulnerability.
http://www.openwall.com/lists/oss-security/2016/03/10/8
Upstream fix: http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/usr.bin/ssh/session.c.diff?r1=1.281&r2=1.282&sortby=date&f=h

Search for package or bug name: Reporting problems