CVE-2016-3191

NameCVE-2016-3191
DescriptionThe compile_branch function in pcre_compile.c in PCRE 8.x before 8.39 and pcre2_compile.c in PCRE2 before 10.22 mishandles patterns containing an (*ACCEPT) substring in conjunction with nested parentheses, which allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow) via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, aka ZDI-CAN-3542.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-441-1
NVD severityhigh (attack range: remote)
Debian Bugs815920, 815921

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre2 (PTS)stretch10.22-3fixed
bullseye, sid, buster10.32-5fixed
pcre3 (PTS)jessie2:8.35-3.3+deb8u4fixed
stretch2:8.39-3fixed
bullseye, sid, buster2:8.39-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre2source(unstable)10.21-1high815920
pcre3source(unstable)2:8.38-2high815921
pcre3sourcejessie2:8.35-3.3+deb8u3high
pcre3sourcesqueeze8.02-1.1+deb6u1highDLA-441-1

Notes

[wheezy] - pcre3 <no-dsa> (Minor issue)
pcre3: http://vcs.pcre.org/pcre?view=revision&revision=1631
pcre2: http://vcs.pcre.org/pcre2?view=revision&revision=489
https://bugs.exim.org/show_bug.cgi?id=1791
https://bugzilla.redhat.com/show_bug.cgi?id=1311503

Search for package or bug name: Reporting problems