CVE-2016-4567

NameCVE-2016-4567
DescriptionCross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs823649

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediaelement (PTS)buster, sid, jessie, stretch2.15.1+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediaelementsource(unstable)(unfixed)unimportant823649

Notes

https://core.trac.wordpress.org/changeset/37370
Fixed by: https://github.com/johndyer/mediaelement/commit/34834eef8ac830b9145df169ec22016a4350f06e
Vulnerable code present, but Flash Player disabled in Debian
See 0004-Deactivate-Flash-and-Silverlight.patch
http://www.openwall.com/lists/oss-security/2016/05/07/2

Search for package or bug name: Reporting problems