DescriptionCross-site scripting (XSS) vulnerability in flash/ in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs823649

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediaelement (PTS)buster2.15.1+dfsg-1vulnerable
bookworm, sid, bullseye2.15.1+dfsg-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs

Fixed by:
Vulnerable code present, but Flash Player disabled in Debian
See 0004-Deactivate-Flash-and-Silverlight.patch

Search for package or bug name: Reporting problems