CVE-2016-5159

NameCVE-2016-5159
DescriptionMultiple integer overflows in OpenJPEG, as used in PDFium in Google Chrome before 53.0.2785.89 on Windows and OS X and before 53.0.2785.92 on Linux, allow remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via crafted JPEG 2000 data that is mishandled during opj_aligned_malloc calls in dwt.c and t1.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3660-1, DSA-3768-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjpeg2 (PTS)buster, buster (security)2.3.0-2+deb10u2fixed
bullseye2.4.0-3fixed
bookworm, sid2.5.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersourcewheezy(unfixed)end-of-life
chromium-browsersourcejessie53.0.2785.89-1~deb8u1DSA-3660-1
chromium-browsersource(unstable)53.0.2785.89-1
openjpeg2sourcejessie2.1.0-2+deb8u2DSA-3768-1
openjpeg2source(unstable)2.1.2-1

Notes

[wheezy] - chromium-browser <end-of-life> (Not supported in Wheezy)
https://github.com/uclouvain/openjpeg/commit/9a07ccb3d0f076388e4da684a3bfd4327125c721

Search for package or bug name: Reporting problems