CVE-2016-5180

NameCVE-2016-5180
DescriptionHeap-based buffer overflow in the ares_create_query function in c-ares 1.x before 1.12.0 allows remote attackers to cause a denial of service (out-of-bounds write) or possibly execute arbitrary code via a hostname with an escaped trailing dot.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-648-1, DSA-3682-1
NVD severityhigh (attack range: remote)
Debian Bugs839151

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
c-ares (PTS)wheezy1.9.1-3vulnerable
wheezy (security)1.9.1-3+deb7u2fixed
jessie1.10.0-2+deb8u2fixed
jessie (security)1.10.0-2+deb8u1fixed
stretch1.12.0-1+deb9u1fixed
buster, sid1.13.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
c-aressource(unstable)1.12.0-1medium839151
c-aressourcejessie1.10.0-2+deb8u1highDSA-3682-1
c-aressourcewheezy1.9.1-3+deb7u1highDLA-648-1

Notes

https://c-ares.haxx.se/adv_20160929.html
https://c-ares.haxx.se/CVE-2016-5180.patch

Search for package or bug name: Reporting problems