CVE-2016-5241

NameCVE-2016-5241
Descriptionmagick/render.c in GraphicsMagick before 1.3.24 allows remote attackers to cause a denial of service (arithmetic exception and application crash) via a crafted svg file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-547-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)wheezy1.3.16-1.1vulnerable
wheezy (security)1.3.16-1.1+deb7u15fixed
jessie1.3.20-3+deb8u1vulnerable
jessie (security)1.3.20-3+deb8u2vulnerable
stretch1.3.25-8fixed
buster, sid1.3.26-19fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.24-1medium
graphicsmagicksourcewheezy1.3.16-1.1+deb7u3mediumDLA-547-1

Notes

Fixed by: http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/8d175c4edfe7

Search for package or bug name: Reporting problems