CVE-2016-5384

NameCVE-2016-5384
Descriptionfontconfig before 2.12.1 does not validate offsets, which allows local users to trigger arbitrary free calls and consequently conduct double free attacks and execute arbitrary code via a crafted cache file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-587-1, DSA-3644-1
NVD severitymedium (attack range: local)
Debian Bugs833570

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fontconfig (PTS)wheezy2.9.0-7.1vulnerable
wheezy (security)2.9.0-7.1+deb7u1fixed
jessie, jessie (security)2.11.0-6.3+deb8u1fixed
stretch2.11.0-6.7fixed
buster, sid2.12.6-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fontconfigsource(unstable)2.11.0-6.5medium833570
fontconfigsourcejessie2.11.0-6.3+deb8u1mediumDSA-3644-1
fontconfigsourcewheezy2.9.0-7.1+deb7u1mediumDLA-587-1

Notes

https://lists.freedesktop.org/archives/fontconfig/2016-August/005792.html
Fixed by: https://cgit.freedesktop.org/fontconfig/commit/?id=7a4a5bd7897d216f0794ca9dbce0a4a5c9d14940 (2.12.1)

Search for package or bug name: Reporting problems