CVE-2016-6128

NameCVE-2016-6128
DescriptionThe gdImageCropThreshold function in gd_crop.c in the GD Graphics Library (aka libgd) before 2.2.3, as used in PHP before 7.0.9, allows remote attackers to cause a denial of service (application crash) via an invalid color index.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3619-1
NVD severitymedium (attack range: remote)
Debian Bugs829062

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2fixed
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie2.1.0-5+deb8u9fixed
jessie (security)2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-3fixed
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.22-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.2-29-g3c2b605-1medium829062
libgd2sourcejessie2.1.0-5+deb8u4mediumDSA-3619-1
libgd2sourcewheezy(not affected)
php5source(unstable)5.6.26+dfsg-1unimportant
php5sourcejessie5.6.26+dfsg-0+deb8u1medium
php5sourcewheezy(not affected)
php7.0source(unstable)7.0.9-1unimportant

Notes

[wheezy] - libgd2 <not-affected> (Vulnerable code not present)
https://github.com/libgd/libgd/compare/3fe0a7128bac5000fdcfab888bd2a75ec0c9447d...fd623025505e87bba7ec8555eeb72dae4fb0afd
Crop support introduced in https://github.com/libgd/libgd/commit/f67452e1f82f1c2496e0859d638172bee74b43a0 (gd-2.1.0-alpha1)
[wheezy] - php5 <not-affected> (Vulnerable code not present)
PHP bug: https://bugs.php.net/bug.php?id=72494
Starting with 5.4.0-1 Debian uses the system copy of libgd

Search for package or bug name: Reporting problems