CVE-2016-6214

NameCVE-2016-6214
Descriptiongd_tga.c in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3619-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2fixed
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie (security), jessie2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.2-29-g3c2b605-1medium
libgd2sourcejessie2.1.0-5+deb8u4mediumDSA-3619-1
libgd2sourcewheezy(not affected)

Notes

[wheezy] - libgd2 <not-affected> (Vulnerable code not present)
https://github.com/libgd/libgd/issues/247#issuecomment-232084241
https://github.com/libgd/libgd/commit/10ef1dca63d62433fda13309b4a228782db823f7
Different issue than CVE-2016-6132
http://www.openwall.com/lists/oss-security/2016/07/13/5

Search for package or bug name: Reporting problems