CVE-2016-6254

NameCVE-2016-6254
DescriptionHeap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-575-1, DSA-3636-1
NVD severitymedium (attack range: remote)
Debian Bugs832507

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
collectd (PTS)wheezy5.1.0-3vulnerable
wheezy (security)5.1.0-3+deb7u3fixed
jessie (security), jessie5.4.1-6+deb8u1fixed
stretch5.7.1-1.1fixed
buster5.7.2-1fixed
sid5.7.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
collectdsource(unstable)5.5.2-1medium832507
collectdsourcejessie5.4.1-6+deb8u1mediumDSA-3636-1
collectdsourcewheezy5.1.0-3+deb7u1mediumDLA-575-1

Notes

https://github.com/collectd/collectd/commit/b589096f907052b3a4da2b9ccc9b0e2e888dfc18
https://github.com/collectd/collectd/commit/8b4fed9940e02138b7e273e56863df03d1a39ef7

Search for package or bug name: Reporting problems