CVE-2016-6620

NameCVE-2016-6620
DescriptionAn issue was discovered in phpMyAdmin. Some data is passed to the PHP unserialize() function without verification that it's valid serialized data. The unserialization can result in code execution because of the interaction with object instantiation and autoloading. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1415-1, DLA-626-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)jessie4:4.2.12-2+deb8u2vulnerable
jessie (security)4:4.2.12-2+deb8u3fixed
stretch4:4.6.6-4fixed
buster, sid4:4.6.6-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)4:4.6.4+dfsg1-1high
phpmyadminsourcejessie4:4.2.12-2+deb8u3highDLA-1415-1
phpmyadminsourcewheezy4:3.4.11.1-2+deb7u6highDLA-626-1

Notes

https://www.phpmyadmin.net/security/PMASA-2016-43/

Search for package or bug name: Reporting problems