CVE-2016-7142

NameCVE-2016-7142
DescriptionThe m_sasl module in InspIRCd before 2.0.23, when used with a service that supports SASL_EXTERNAL authentication, allows remote attackers to spoof certificate fingerprints and consequently log in as another user via a crafted SASL message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3662-1
NVD severitymedium (attack range: remote)
Debian Bugs836706

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
inspircd (PTS)wheezy, wheezy (security)2.0.5-1+deb7u2vulnerable
jessie (security), jessie2.0.17-1+deb8u2fixed
stretch2.0.23-2fixed
buster, sid2.0.24-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
inspircdsource(unstable)2.0.23-1medium836706
inspircdsourcejessie2.0.17-1+deb8u2mediumDSA-3662-1
inspircdsourcewheezy(unfixed)end-of-life

Notes

[wheezy] - inspircd <end-of-life> (not supported in Wheezy)
http://www.inspircd.org/2016/09/03/v2023-released.html
http://www.openwall.com/lists/oss-security/2016/09/04/3

Search for package or bug name: Reporting problems