CVE-2016-7168

NameCVE-2016-7168
DescriptionCross-site scripting (XSS) vulnerability in the media_handle_upload function in wp-admin/includes/media.php in WordPress before 4.6.1 might allow remote attackers to inject arbitrary web script or HTML by tricking an administrator into uploading an image file that has a crafted filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-633-1, DSA-3681-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10vulnerable
wheezy (security)3.6.1+dfsg-1~deb7u16fixed
jessie4.1+dfsg-1+deb8u14fixed
jessie (security)4.1+dfsg-1+deb8u15fixed
stretch4.7.5+dfsg-2fixed
stretch (security)4.7.5+dfsg-2+deb9u1fixed
buster, sid4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.6.1+dfsg-1low
wordpresssourcejessie4.1+dfsg-1+deb8u10lowDSA-3681-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u12lowDLA-633-1

Notes

https://wordpress.org/news/2016/09/wordpress-4-6-1-security-and-maintenance-release/
Fixed in 4.6.1 release upstream
Fixed by: https://core.trac.wordpress.org/changeset/38538

Search for package or bug name: Reporting problems