CVE-2016-7415

NameCVE-2016-7415
DescriptionStack-based buffer overflow in the Locale class in common/locid.cpp in International Components for Unicode (ICU) through 57.1 for C/C++ allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a long locale string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-744-1, DSA-3725-1
NVD severityhigh (attack range: remote)
Debian Bugs838694

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icu (PTS)wheezy4.8.1.1-12+deb7u3vulnerable
wheezy (security)4.8.1.1-12+deb7u7fixed
jessie52.1-8+deb8u6fixed
jessie (security)52.1-8+deb8u5fixed
stretch57.1-6+deb9u1fixed
buster, sid57.1-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icusource(unstable)57.1-5high838694
icusourceexperimental58.1-1high
icusourcejessie52.1-8+deb8u4highDSA-3725-1
icusourcewheezy4.8.1.1-12+deb7u6highDLA-744-1

Notes

Related code in http://source.icu-project.org/repos/icu/icu/trunk/source/common/locid.cpp file
PHP Bug: https://bugs.php.net/bug.php?id=73007
PHP fix: https://github.com/php/php-src/commit/6d55ba265637d6adf0ba7e9c9ef11187d1ec2f5b?w=1
Upstream bug: http://bugs.icu-project.org/trac/ticket/12745

Search for package or bug name: Reporting problems