CVE-2016-7446

NameCVE-2016-7446
DescriptionBuffer overflow in the MVG and SVG rendering code in GraphicsMagick 1.3.24 allows remote attackers to have unspecified impact via unknown vectors. Note: This vulnerability exists due to an incomplete patch for CVE-2016-2317.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-651-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)wheezy1.3.16-1.1vulnerable
wheezy (security)1.3.16-1.1+deb7u7fixed
jessie1.3.20-3+deb8u1vulnerable
jessie (security)1.3.20-3+deb8u2vulnerable
stretch1.3.25-8fixed
buster, sid1.3.26-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.25-1high
graphicsmagicksourcewheezy1.3.16-1.1+deb7u4highDLA-651-1

Notes

For the http://www.graphicsmagick.org/NEWS.html#september-5-2016 case
which remained present in the 1.3.24 release (and was not fixed until 1.3.25)
Fixed by http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/6071b5820215

Search for package or bug name: Reporting problems