CVE-2016-7543

NameCVE-2016-7543
DescriptionBash before 4.4 allows local users to execute arbitrary commands with root privileges via crafted SHELLOPTS and PS4 environment variables.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-680-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bash (PTS)wheezy4.2+dfsg-0.1+deb7u3vulnerable
wheezy (security)4.2+dfsg-0.1+deb7u4fixed
jessie4.3-11+deb8u1fixed
buster, sid, stretch4.4-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bashsource(unstable)4.4-1high
bashsourcejessie4.3-11+deb8u1high
bashsourcewheezy4.2+dfsg-0.1+deb7u4highDLA-680-1

Notes

http://www.openwall.com/lists/oss-security/2016/09/26/9
Default shell is dash which is not vulnerable, but bash in Jessie and
Wheezy are affected.
Fixed by (4.3): https://ftp.gnu.org/pub/gnu/bash/bash-4.3-patches/bash43-048

Search for package or bug name: Reporting problems