CVE-2016-7553

NameCVE-2016-7553
DescriptionThe buf.pl script before 2.20 in Irssi before 0.8.20 uses weak permissions for the scrollbuffer dump file created between upgrades, which might allow local users to obtain sensitive information from private chat conversations by reading the file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-722-1
NVD severitylow
Debian Bugs838762

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)stretch (security), stretch1.0.7-1~deb9u1fixed
buster1.2.0-2+deb10u1fixed
bookworm, sid, bullseye1.2.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisourcewheezy0.8.15-5+deb7u1DLA-722-1
irssisourcejessie0.8.17-1+deb8u2
irssisource(unstable)0.8.20-2838762

Notes

Fixed by: https://github.com/irssi/scripts.irssi.org/commit/f1b1eb154baa684fad5d65bf4dff79c8ded8b65a
https://irssi.org/2016/09/22/buf.pl-update/
https://www.openwall.com/lists/oss-security/2016/09/24/1

Search for package or bug name: Reporting problems