Information on source package irssi

Available versions

ReleaseVersion
jessie (security)0.8.17-1+deb8u5
stretch1.0.2-1+deb9u3
stretch (security)1.0.7-1~deb9u1
buster1.0.7-1
sid1.0.7-1

Open issues

BugjessiestretchbustersidDescription
CVE-2018-7052vulnerable (no DSA, ignored)fixedfixedfixedAn issue was discovered in Irssi before 1.0.7 and 1.1.x before 1.1.1. ...
CVE-2018-7051vulnerable (no DSA, ignored)fixedfixedfixedAn issue was discovered in Irssi before 1.0.7 and 1.1.x before 1.1.1. ...
CVE-2018-7050vulnerable (no DSA, ignored)fixedfixedfixedAn issue was discovered in Irssi before 1.0.7 and 1.1.x before 1.1.1. A ...
CVE-2018-5208vulnerable (no DSA, ignored)fixedfixedfixedIn Irssi before 1.0.6, a calculation error in the completion code could ...
CVE-2018-5207vulnerable (no DSA, ignored)fixedfixedfixedWhen using an incomplete variable argument, Irssi before 1.0.6 may ...
CVE-2018-5206vulnerable (no DSA, ignored)fixedfixedfixedWhen the channel topic is set without specifying a sender, Irssi before ...
CVE-2018-5205vulnerable (no DSA, ignored)fixedfixedfixedWhen using incomplete escape codes, Irssi before 1.0.6 may access data ...

Open unimportant issues

BugjessiestretchbustersidDescription
TEMP-0000000-E6792Fvulnerablefixedfixedfixedirssi missing null terminator

Resolved issues

BugDescription
TEMP-0855108-573218irssi memory leak
CVE-2018-7054An issue was discovered in Irssi before 1.0.7 and 1.1.x before 1.1.1. ...
CVE-2018-7053An issue was discovered in Irssi before 1.0.7 and 1.1.x before 1.1.1. ...
CVE-2017-9469In Irssi before 1.0.3, when receiving certain incorrectly quoted DCC ...
CVE-2017-9468In Irssi before 1.0.3, when receiving a DCC message without source ...
CVE-2017-7191The netjoin processing in Irssi 1.x before 1.0.2 allows attackers to ...
CVE-2017-5356Irssi before 0.8.21 allows remote attackers to cause a denial of ...
CVE-2017-5196Irssi 0.8.18 before 0.8.21 allows remote attackers to cause a denial ...
CVE-2017-5195Irssi 0.8.17 before 0.8.21 allows remote attackers to cause a denial ...
CVE-2017-5194Use-after-free vulnerability in Irssi before 0.8.21 allows remote ...
CVE-2017-5193The nickcmp function in Irssi before 0.8.21 allows remote attackers to ...
CVE-2017-15723In Irssi before 1.0.5, overlong nicks or targets may result in a NULL ...
CVE-2017-15722In certain cases, Irssi before 1.0.5 may fail to verify that a Safe ...
CVE-2017-15721In Irssi before 1.0.5, certain incorrectly formatted DCC CTCP messages ...
CVE-2017-15228Irssi before 1.0.5, when installing themes with unterminated colour ...
CVE-2017-15227Irssi before 1.0.5, while waiting for the channel synchronisation, may ...
CVE-2017-10966An issue was discovered in Irssi before 1.0.4. While updating the ...
CVE-2017-10965An issue was discovered in Irssi before 1.0.4. When receiving messages ...
CVE-2016-7553The buf.pl script before 2.20 in Irssi before 0.8.20 uses weak ...
CVE-2016-7045The format_send_to_gui function in the format parsing code in Irssi ...
CVE-2016-7044The unformat_24bit_color function in the format parsing code in Irssi ...
CVE-2010-1156core/nicklist.c in Irssi before 0.8.15 allows remote attackers to ...
CVE-2010-1155Irssi before 0.8.15, when SSL is used, does not verify that the server ...
CVE-2009-1959Off-by-one error in the event_wallops function in ...

Security announcements

DSA / DLADescription
DSA-4162-1irssi - security update
DLA-1318-1irssi - security update
DLA-1289-1irssi - security update
DLA-1217-1irssi - security update
DSA-4016-1irssi - security update
DSA-4016-1irssi - security update
DLA-1089-1irssi - security update
DLA-1088-1irssi - security update
DSA-3885-1irssi - security update
DSA-3885-1irssi - security update
DLA-722-1irssi - security update
DSA-3672-1irssi - security update

Search for package or bug name: Reporting problems