CVE-2016-7787

NameCVE-2016-7787
DescriptionA maliciously crafted command line for kdesu can result in the user only seeing part of the commands that will actually get executed as super user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs839865, 842498, 843790

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde-cli-tools (PTS)stretch4:5.8.4-1fixed
sid4:5.8.4-2fixed
kde-runtime (PTS)wheezy4:4.8.4-2fixed
jessie4:4.14.2-2vulnerable
stretch, sid4:16.08.3-2fixed
kdesudo (PTS)wheezy3.4.2.4-2fixed
stretch, sid, jessie3.4.2.4-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kde-cli-toolssource(unstable)4:5.8.0-1medium839865
kde-runtimesource(unstable)4:16.08.3-2medium842498
kde-runtimesourcewheezy(not affected)
kdesudosource(unstable)(unfixed)medium843790
kdesudosourcewheezy(not affected)

Notes

[jessie] - kde-runtime <no-dsa> (Minor issue)
[wheezy] - kde-runtime <not-affected> (Unicode string terminator is not interpreted)
[jessie] - kdesudo <no-dsa> (Minor issue)
[wheezy] - kdesudo <not-affected> (Unicode string terminator is not interpreted)
https://www.kde.org/info/security/advisory-20160930-1.txt
https://github.com/KDE/kde-cli-tools/commit/5eda179a099ba68a20dc21dc0da63e85a565a171
For kde-cli-tools fixed in 5.7.5 upstream
kde-runtime's affected binary is /usr/lib/kde4/libexec/kdesu-distrib/kdesu
kdesudo's affected binary is /usr/bin/kdesudo

Search for package or bug name: Reporting problems